Bug 17206 - if i paste this into my windows 3.3.2 R console, it crashes
Summary: if i paste this into my windows 3.3.2 R console, it crashes
Status: CLOSED FIXED
Alias: None
Product: R
Classification: Unclassified
Component: Windows GUI / Window specific (show other bugs)
Version: R 3.3.0
Hardware: x86_64/x64/amd64 (64-bit) Windows 64-bit
: P5 trivial
Assignee: R-core
URL:
Depends on:
Blocks:
 
Reported: 2017-01-07 12:44 UTC by Anthony Damico
Modified: 2017-01-07 15:05 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Damico 2017-01-07 12:44:04 UTC
# crash R with this command
dir.create( "C:/My Directory/PEW/Hispanic Trends/2015/2013 Recontact Survey of Asian Ame
ricans              Field dates: 10/16/13 - 10/31/13 Respondents: Nationally-rep
resentative sample of 802 Asian Americans ages 18 and older. Margin of Error: +/
- 5.0 percentage points at the 95% confidence interval. This survey focused on p
olitics, attitudes regarding immigration legislation, illegal immigration, and n
aturalization./"  , recursive = TRUE , showWarnings = FALSE )



> sessionInfo()
R version 3.3.2 (2016-10-31)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 10586)

locale:
[1] LC_COLLATE=English_United States.1252
[2] LC_CTYPE=English_United States.1252  
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                         
[5] LC_TIME=English_United States.1252   

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base
Comment 1 Duncan Murdoch 2017-01-07 15:03:33 UTC
The issue is that the path is too long, and a check of the length was missed before it was written into a fixed size buffer.  I've fixed that (and a few other similar occurences).  Will commit to R-devel and R-patched soon.
Comment 2 Anthony Damico 2017-01-07 15:05:40 UTC
thank you so much