Bug 16599 - Installation breaks because of wrong libcurl version
Summary: Installation breaks because of wrong libcurl version
Status: UNCONFIRMED
Alias: None
Product: R
Classification: Unclassified
Component: Installation (show other bugs)
Version: R-devel (trunk)
Hardware: x86_64/x64/amd64 (64-bit) Linux-RHEL
: P5 enhancement
Assignee: R-core
URL:
Depends on:
Blocks:
 
Reported: 2015-11-12 11:29 UTC by Sajoscha Sauer
Modified: 2015-11-12 11:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sajoscha Sauer 2015-11-12 11:29:24 UTC
Hello, 
We tried to install R-devel (2015-11-12 r69623) and R-3.2.2 on our CentOS 6.5 server. This gave an error because of libcurl 7.28.0 or later is required. 

Now to not screw with the hosting system we installed curl within the installation folder and gave the library as a flag to the configure script. 

./configure LDFLAGS="-L/path/to/curl/lib"

The configure does not complain, but the make script stops with the error: 

libcurl.c:40:3: error: #error libcurl 7.28.0 or later is required.

We found two ways to solve this: 
1. the ugly one is just to run make again, which results in a functional installation
2. set the path to the curl binaries 

Now the question is, does R need the curl binary to be > 7.28.0 or only the libraries? 


Cheers, 
Sajoscha