Bug 16329 - RSiteSearch fails for all search strings
Summary: RSiteSearch fails for all search strings
Status: CLOSED FIXED
Alias: None
Product: R
Classification: Unclassified
Component: Misc (show other bugs)
Version: R 3.2.0
Hardware: x86_64/x64/amd64 (64-bit) Linux-Ubuntu
: P5 normal
Assignee: R-core
URL:
Depends on:
Blocks:
 
Reported: 2015-04-23 00:47 UTC by Simon Blomberg
Modified: 2015-05-02 17:48 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Blomberg 2015-04-23 00:47:06 UTC
RSiteSearch() fails for all search strings that I have tried. During a discussion on r-downunder, Bill Venables finds that RSiteSearch() is broken on Windows R.3.2.0 too. Bill told me to file a bug report, so here it is. (I always take Bill's advice.)

>  RSiteSearch("{logistic regression}") # example from the help page

A search query has been submitted to http://search.r-project.org
The results page should open in your browser shortly

# NB: No browser opens and the following error is thrown:
>
gvfs-open: http%3A%2F%2Fsearch.r-project.org%2Fcgi-bin%2Fnamazu.cgi%3Fquery%3D%7Blogistic%2Bregression%7D&max=20&result=normal&sort=score&idxname=functions&idxname=vignettes&idxname=views: error opening location: Error when getting information for file '/home/simonb/http%3A%2F%2Fsearch.r-project.org%2Fcgi-bin%2Fnamazu.cgi%3Fquery%3D%7Blogistic%2Bregression%7D&max=20&result=normal&sort=score&idxname=functions&idxname=vignettes&idxname=views': No such file or directory

I'm using ESS  version 15.03-1utopic0 with emacs version 24.3+1-4ubuntu1 on Ubuntu 14.10. However, I get the same error if I run R from a bash shell. I'm using FireFox 37.0.1 as my browser.

platform       x86_64-pc-linux-gnu         
arch           x86_64                      
os             linux-gnu                   
system         x86_64, linux-gnu           
status                                     
major          3                           
minor          2.0                         
year           2015                        
month          04                          
day            16                          
svn rev        68180                       
language       R                           
version.string R version 3.2.0 (2015-04-16)
nickname       Full of Ingredients
Comment 1 Duncan Murdoch 2015-05-01 11:35:55 UTC
Fixed in R-devel and R-patched as of rev 68297.