Bug 15406 - R -e "" crashes on Windows (but not Rterm -e "" or R -e " ")
R -e "" crashes on Windows (but not Rterm -e "" or R -e " ")
Status: CLOSED FIXED
Product: R
Classification: Unclassified
Component: Startup
R-devel (trunk)
x86_64/x64/amd64 (64-bit) Windows 64-bit
: P5 major
Assigned To: R-core
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 18:54 UTC by Henrik Bengtsson
Modified: 2013-07-28 21:01 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik Bengtsson 2013-07-28 18:54:06 UTC
On Windows, the following crashes "R for Windows terminal front-end":

R -e ""

whereas

Rterm -e "" or R -e " " (a space in the expression) doesn't.

I observe this on:

- R Under development (unstable) (2013-07-26 r63419) [Platform:
x86_64-w64-mingw32/x64 (64-bit)]
- R version 3.0.1 Patched (2013-07-25 r63414) [Platform:
x86_64-w64-mingw32/x64 (64-bit)]
- R version 3.0.1 (2013-05-16) [Platform: x86_64-w64-mingw32/x64 (64-bit)]
- R version 2.15.3 Patched (2013-03-13 r62402) [Platform:
x86_64-w64-mingw32/x64 (64-bit)]

/Henrik
Comment 1 Duncan Murdoch 2013-07-28 20:00:02 UTC
The problem is that 
R -e "" 
runs
Rterm -e
(i.e. the quotes get eaten by the argument processing).  Should be easy to fix...
Comment 2 Duncan Murdoch 2013-07-28 21:01:09 UTC
Fixed in R-devel and R-patched.  Windows now behaves differently from Unix in that it accepts

R -e ""

(and executes an empty command) whereas Unix reports that as an error.  Not sure if Unix users would consider that to be a bug or not.