Bug 14691 - Invalid parameter to loess.smooth crash R
Invalid parameter to loess.smooth crash R
Status: CLOSED FIXED
Product: R
Classification: Unclassified
Component: Low-level
R 2.13.1
All All
: P5 normal
Assigned To: R-core
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-29 21:48 UTC by give_me_more_spam
Modified: 2011-10-03 12:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description give_me_more_spam 2011-09-29 21:48:20 UTC
If invalid (zero length) parameter span or degree is passed to loess.smooth then it's crash R:

  loess.smooth(1:10, 1:10, span=numeric(0))

Crash is caused by .C(R_loess_raw, ...)