Bug 14628 - faulty graphics windows output?
faulty graphics windows output?
Status: RESOLVED FIXED
Product: R
Classification: Unclassified
Component: Graphics
R 2.13.1 patched
x86_64/x64/amd64 (64-bit) Windows 64-bit
: P3 major
Assigned To: R-core
: 14632 14683 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-14 06:27 UTC by karl ropkins
Modified: 2011-09-21 08:49 UTC (History)
6 users (show)

See Also:


Attachments
example faulty graphics output (130.35 KB, image/pjpeg)
2011-07-14 06:27 UTC, karl ropkins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karl ropkins 2011-07-14 06:27:48 UTC
Created attachment 1209 [details]
example faulty graphics output

In 2.13.1 and 2.13.1 pacthed graphics outputs have missing horiziontal and vertical instances (typically 1 pixel width, guess) when graduated colour plotted. See for example,

> require(grDevices) # for colours
> x <- y <- seq(-4*pi, 4*pi, len=27)
> r <- sqrt(outer(x^2, y^2, "+"))
> image(z = z <- cos(r^2)*exp(-r/6), col=gray((0:32)/32))

Similar for (lattice) levelplot, both colour surface and associated color.key, and other similar functions, e.g. polarPlot in openair.

(Don't see with 2.13.0 when reinstalled, also don't see in pdf outputs but do with some other outputs, e.g. jpg. Would guess this problem was in grid, but very much a newbie at this type of thing.)

Kind regards,

Karl
Comment 1 kassteele 2011-07-14 14:57:40 UTC
(In reply to comment #0)
> Created an attachment (id=1209) [details]
> example faulty graphics output
> 
> In 2.13.1 and 2.13.1 pacthed graphics outputs have missing horiziontal and
> vertical instances (typically 1 pixel width, guess) when graduated colour
> plotted. See for example,
> 
> > require(grDevices) # for colours
> > x <- y <- seq(-4*pi, 4*pi, len=27)
> > r <- sqrt(outer(x^2, y^2, "+"))
> > image(z = z <- cos(r^2)*exp(-r/6), col=gray((0:32)/32))
> 
> Similar for (lattice) levelplot, both colour surface and associated color.key,
> and other similar functions, e.g. polarPlot in openair.
> 
> (Don't see with 2.13.0 when reinstalled, also don't see in pdf outputs but do
> with some other outputs, e.g. jpg. Would guess this problem was in grid, but
> very much a newbie at this type of thing.)
> 
> Kind regards,
> 
> Karl

Same problem here (R-2.13.1 and R-2.13.1 patched). Just try:

image(volcano)

It shows the same white lines.

Best regards,
Jan van de Kassteele
Comment 2 Peter Dalgaard 2011-07-14 15:15:15 UTC
Please state platform. Not happening for me, on OSX 10.6.8.
Comment 3 kassteele 2011-07-14 15:25:06 UTC
(In reply to comment #2)
> Please state platform. Not happening for me, on OSX 10.6.8.

Windows XP professional SP3
Comment 4 Gilbert 2011-07-17 11:03:03 UTC
Same problem under Win 7 64bit. Most TraMineR's graphics become unusable.

Following example generates the white lines, either vertically or horizontally:

x <- rep(1,100)
barplot(x, space=0, border=NA) 
barplot(x, horiz=TRUE, space=0, border=NA)


Best regards,
Gilbert
Comment 5 Gilbert 2011-07-18 09:16:01 UTC
some additional information:

- white lines change randomly when resizing the window

- white lines are clearly visible in bitmat graphics produced with png() and jpeg() for instance. They are visible in printed png or jpeg output as well. This is new and did not occur in R-2.13.0

- pdf() and ps(): white lines are not visible in Acrobat, but light white lines are visible with other viewers such as in SumatraPDF or in GSview. This was already the case in R-2.13.0. In any case, no lines show up in printed outputs. 

- When converting (with Imagemagick and gswin64) pdf or ps files obtained with pdf() or postscript() into png or jpeg, the resulting graphics also show up some light white lines. This was already the case with R-2.13.0.

Hope this may help.

Gilbert
Comment 6 Duncan Murdoch 2011-07-18 12:23:37 UTC
This is a consequence of the fix to PR #14583.  A better fix will be put in place.
Comment 7 Duncan Murdoch 2011-07-18 12:26:17 UTC
*** Bug 14632 has been marked as a duplicate of this bug. ***
Comment 8 Duncan Murdoch 2011-07-18 13:23:41 UTC
Fixed in R-devel and R-patched.
Comment 9 rilou.furynx 2011-09-21 08:49:18 UTC
*** Bug 14683 has been marked as a duplicate of this bug. ***