Bug 14608 - html documentaion for "Arithmetic Operators"
html documentaion for "Arithmetic Operators"
Status: CLOSED FIXED
Product: R
Classification: Unclassified
Component: Documentation
R 2.13.0
ix86 (32-bit) Linux-Debian
: P5 minor
Assigned To: R-core
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-17 06:53 UTC by David Harte
Modified: 2011-06-18 13:42 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Harte 2011-06-17 06:53:30 UTC
This problem is not restricted to the Debian (Squeeze) machines. Exactly the same thing occurs in Windows XP (32 bit).

To repeat the problem:
At R prompt:
help.start()

Web browser help system appears
Select "Search Engine & Keywords"
Enter "Arithmetic Operators"

The following hyperlink appears:
base::+
   Arithmetic Operators

Click on the hyperlink, and it says:
"Link in package base could not be located"

The hyperlink is pointing to "... /base/html/+.html", 
I suspect it should be: "... /base/html/Arithmetic.html"
Comment 1 Duncan Murdoch 2011-06-17 16:32:27 UTC
On 11-06-17 1:53 AM, r-bugs@r-project.org wrote:
> https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14608
>
>             Summary: html documentaion for "Arithmetic Operators"
>             Product: R
>             Version: R 2.13.0
>            Platform: ix86 (32-bit)
>          OS/Version: Linux-Debian
>              Status: NEW
>            Severity: minor
>            Priority: P5
>           Component: Documentation
>          AssignedTo: R-core@R-project.org
>          ReportedBy: d.s.harte@gmail.com
>     Estimated Hours: 0.0
>
>
> This problem is not restricted to the Debian (Squeeze) machines. Exactly the
> same thing occurs in Windows XP (32 bit).
>
> To repeat the problem:
> At R prompt:
> help.start()
>
> Web browser help system appears
> Select "Search Engine&  Keywords"
> Enter "Arithmetic Operators"
>
> The following hyperlink appears:
> base::+
>     Arithmetic Operators
>
> Click on the hyperlink, and it says:
> "Link in package base could not be located"
>
> The hyperlink is pointing to "... /base/html/+.html",
> I suspect it should be: "... /base/html/Arithmetic.html"
>


Thanks, this is a problem in the URL generated by the search engine. 
For most topics the topic matches the filename, but not in this case, 
and the search engine was using the wrong one.

Duncan Murdoch


Comment 2 Duncan Murdoch 2011-06-18 13:42:24 UTC
Fixed as of r56173 in R-devel and R-patched.