Bug 14460 - RGui script editor: Cursor jumps aroun when running commands with Ctrl-R
RGui script editor: Cursor jumps aroun when running commands with Ctrl-R
Status: RESOLVED FIXED
Product: R
Classification: Unclassified
Component: Windows GUI / Window specific
R 2.12.0
Other Other
: P5 enhancement
Assigned To: R-core
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-16 11:34 UTC by Ram Dessau
Modified: 2010-12-16 19:38 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ram Dessau 2010-12-16 11:34:08 UTC
Problem since 2.12.0 also in 2.12.1 RC
OK in 2.11.1

I use the RGui editor routinely. The curser blinks not on the current line after running a command with Ctrl-R.
This is a small, but annoying problem. 
So at the moment i stick to version 2.11.1

Tried on different XP SP3 windows PC's, the same problem. 

Greetings Ram
Comment 1 Duncan Murdoch 2010-12-16 19:11:01 UTC
On 16/12/2010 5:34 AM, r-bugs@r-project.org wrote:
> https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14460
>
>             Summary: RGui script editor: Cursor jumps aroun when running
>                      commands with Ctrl-R
>             Product: R
>             Version: R 2.12.0
>            Platform: Other
>          OS/Version: Other
>              Status: NEW
>            Severity: enhancement
>            Priority: P5
>           Component: Windows GUI / Window specific
>          AssignedTo: R-core@R-project.org
>          ReportedBy: ramd@regionsjaelland.dk
>     Estimated Hours: 0.0
>
>
> Problem since 2.12.0 also in 2.12.1 RC
> OK in 2.11.1
>
> I use the RGui editor routinely. The curser blinks not on the current line
> after running a command with Ctrl-R.
> This is a small, but annoying problem.
> So at the moment i stick to version 2.11.1
>
> Tried on different XP SP3 windows PC's, the same problem.
>
> Greetings Ram
>


I can confirm this, but it will be a while before I can look at it.  If 
you want to track down a patch it would be appreciated.

Duncan Murdoch


Comment 2 Duncan Murdoch 2010-12-16 19:36:20 UTC
On 16/12/2010 5:34 AM, r-bugs@r-project.org wrote:
> https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14460
>
>             Summary: RGui script editor: Cursor jumps aroun when running
>                      commands with Ctrl-R
>             Product: R
>             Version: R 2.12.0
>            Platform: Other
>          OS/Version: Other
>              Status: NEW
>            Severity: enhancement
>            Priority: P5
>           Component: Windows GUI / Window specific
>          AssignedTo: R-core@R-project.org
>          ReportedBy: ramd@regionsjaelland.dk
>     Estimated Hours: 0.0
>
>
> Problem since 2.12.0 also in 2.12.1 RC
> OK in 2.11.1
>
> I use the RGui editor routinely. The curser blinks not on the current line
> after running a command with Ctrl-R.
> This is a small, but annoying problem.
> So at the moment i stick to version 2.11.1
>
> Tried on different XP SP3 windows PC's, the same problem.
>
> Greetings Ram
>


In case someone else wants to look into this, here are instructions to 
reproduce:

Start an empty R session.  Open a new editor window (menu item New 
Script), put

x <- 1

in the first line.  While the cursor is still on that line, hit Ctrl-R 
to run it.

At this point the cursor in the editor window moves about 3/4 down the 
editor window.  It appears to me as though it is using the position of 
the cursor in the console window to choose the line to move to, rather 
than the editor window position.

This is probably related to the changes I made to support screen readers 
for visually impaired users.

Duncan Murdoch


Comment 3 Duncan Murdoch 2010-12-16 19:38:42 UTC
Fixed in r53861/r53862
Comment 4 Duncan Murdoch 2010-12-17 00:02:50 UTC
On 16/12/2010 8:36 AM, Duncan Murdoch wrote:
> On 16/12/2010 5:34 AM, r-bugs@r-project.org wrote:
> >  https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14460
> >
> >              Summary: RGui script editor: Cursor jumps aroun when running
> >                       commands with Ctrl-R
> >              Product: R
> >              Version: R 2.12.0
> >             Platform: Other
> >           OS/Version: Other
> >               Status: NEW
> >             Severity: enhancement
> >             Priority: P5
> >            Component: Windows GUI / Window specific
> >           AssignedTo: R-core@R-project.org
> >           ReportedBy: ramd@regionsjaelland.dk
> >      Estimated Hours: 0.0
> >
> >
> >  Problem since 2.12.0 also in 2.12.1 RC
> >  OK in 2.11.1
> >
> >  I use the RGui editor routinely. The curser blinks not on the current line
> >  after running a command with Ctrl-R.
> >  This is a small, but annoying problem.
> >  So at the moment i stick to version 2.11.1
> >
> >  Tried on different XP SP3 windows PC's, the same problem.
> >
> >  Greetings Ram
> >
>
> In case someone else wants to look into this, here are instructions to
> reproduce:
>
> Start an empty R session.  Open a new editor window (menu item New
> Script), put
>
> x<- 1
>
> in the first line.  While the cursor is still on that line, hit Ctrl-R
> to run it.
>
> At this point the cursor in the editor window moves about 3/4 down the
> editor window.  It appears to me as though it is using the position of
> the cursor in the console window to choose the line to move to, rather
> than the editor window position.
>
> This is probably related to the changes I made to support screen readers
> for visually impaired users.
>
> Duncan Murdoch


I found some time for this, and have fixed it.  I will soon commit the 
fix to R-devel and R-patched.

Duncan Murdoch