Bug 14335 - Documents open in the R.app editor become unresponsive or do not update changes
Summary: Documents open in the R.app editor become unresponsive or do not update changes
Status: UNCONFIRMED
Alias: None
Product: R
Classification: Unclassified
Component: Mac GUI / Mac specific (show other bugs)
Version: R 2.11.1
Hardware: ix86 (32-bit) Mac OS X v10.6
: P5 major
Assignee: Simon Urbanek
URL:
Depends on:
Blocks:
 
Reported: 2010-07-14 20:14 UTC by joey reid
Modified: 2011-03-21 18:01 UTC (History)
0 users

See Also:


Attachments
screenshot of active buy unresponsive Editor window (1.06 MB, application/pdf)
2010-07-14 20:14 UTC, joey reid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description joey reid 2010-07-14 20:14:44 UTC
Created attachment 1114 [details]
screenshot of active buy unresponsive Editor window

I'm still not exactly sure how to trigger it, but i happens to me often enough that this is a major problem. While editing multiple documents in the R.app editor, one or more become unresponsive to the cursor. I think that changes can still be made to the open documents, but the changes are not updated on the screen. I can still create a new document in the editor, and it acts like a document should, fully editable and responsive. 

I've attached a screenshot of the problem. In the screenshot you can see the frontmost window is missing the icons and search bar that should be along the top of it, whereas the editor window to the bottom left remains fully functional and has its full complement of icons and search bar. If you look closely at the frontmost editor window ("Angelo Analysis") you can see multiple cursors at the same time.
Comment 1 Simon Urbanek 2011-03-21 14:50:52 UTC
I can't reproduce it but in GUI 1.40 we have a new editor so maybe it helps - please try the current R 2.13.0 alpha and advise whether the issue remains. Thanks, Simon.