Bug 14155 - Wrong links in help help files?
Wrong links in help help files?
Status: CLOSED FIXED
Product: R
Classification: Unclassified
Component: Documentation
old
All All
: P5 normal
Assigned To: Jitterbug compatibility account
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-17 15:04 UTC by Jitterbug compatibility account
Modified: 2009-12-17 21:04 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jitterbug compatibility account 2009-12-17 15:04:01 UTC
From: Henrik Parn <henrik.parn@bio.ntnu.no>
Dear R developers,


?help.search

...opens a tab in my browser (Firefox 3.5.6, Win XP):

http://127.0.0.1:31642/library/utils/html/help.search.html

When I click on the link for "?", 
(http://127.0.0.1:31642/library/utils/help/?)
in the last line of "Details", I get an error message:

"Server error: invalid response from R".


Similarly,

The link to "??" (http://127.0.0.1:31642/library/utils/help/??) found 
under http://127.0.0.1:31642/library/utils/html/help.html "See also" 
gives same error message.


On the other hand, in the help text for "help" 
(http://127.0.0.1:31642/library/utils/html/help.html) the link to "?", 
found under "See also", is 
http://127.0.0.1:31642/library/utils/html/Question.html, which seems to 
be the correct link.


I did not manage to find anything on this topic in recent bug reports on 
"Documentation" and "Documentation fixed".


Best regards,


Henrik Pärn


 > sessionInfo()
R version 2.10.1 (2009-12-14)
i386-pc-mingw32

locale:
[1] LC_COLLATE=English_United Kingdom.1252  LC_CTYPE=English_United 
Kingdom.1252    LC_MONETARY=English_United Kingdom.1252 LC_NUMERIC=C 

[5] LC_TIME=English_United Kingdom.1252

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

loaded via a namespace (and not attached):
[1] tools_2.10.1

  	
-- 
Henrik Pärn
Centre for Conservation Biology
Department of Biology
Norwegian University of Science and Technology
NO-7491 Trondheim
Norway

Office: +47 73596285
Fax: +47 73596100
Mobile: +47 90989255

E-mail: henrik.parn@bio.ntnu.no

Comment 1 Jitterbug compatibility account 2009-12-17 18:31:15 UTC
From: Duncan Murdoch <murdoch@stats.uwo.ca>
On 17/12/2009 4:05 AM, henrik.parn@bio.ntnu.no wrote:
> Dear R developers,
> 
> 
> ?help.search
> 
> ...opens a tab in my browser (Firefox 3.5.6, Win XP):
> 
> http://127.0.0.1:31642/library/utils/html/help.search.html
> 
> When I click on the link for "?", 
> (http://127.0.0.1:31642/library/utils/help/?)
> in the last line of "Details", I get an error message:
> 
> "Server error: invalid response from R".
> 
> 
> Similarly,
> 
> The link to "??" (http://127.0.0.1:31642/library/utils/help/??) found 
> under http://127.0.0.1:31642/library/utils/html/help.html "See also" 
> gives same error message.
> 
> 
> On the other hand, in the help text for "help" 
> (http://127.0.0.1:31642/library/utils/html/help.html) the link to "?", 
> found under "See also", is 
> http://127.0.0.1:31642/library/utils/html/Question.html, which seems to 
> be the correct link.
> 
> 
> I did not manage to find anything on this topic in recent bug reports on 
> "Documentation" and "Documentation fixed".

Thanks.  The problem is that the HTML converter doesn't escape the 
question marks, which have special meaning in a URL, so they are 
misinterpreted.  I'll look into it.

Duncan Murdoch

> 
> 
> Best regards,
> 
> 
> Henrik Pärn
> 
> 
>  > sessionInfo()
> R version 2.10.1 (2009-12-14)
> i386-pc-mingw32
> 
> locale:
> [1] LC_COLLATE=English_United Kingdom.1252  LC_CTYPE=English_United 
> Kingdom.1252    LC_MONETARY=English_United Kingdom.1252 LC_NUMERIC=C 
> 
> [5] LC_TIME=English_United Kingdom.1252
> 
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods   base
> 
> loaded via a namespace (and not attached):
> [1] tools_2.10.1
> 
>

Comment 2 Jitterbug compatibility account 2009-12-17 21:04:43 UTC
From: Duncan Murdoch <murdoch@stats.uwo.ca>
This is now fixed in R-devel and R-patched as of  r50774.  It should 
show up in Windows builds tomorrow.  There were probably other special 
characters besides "?" that it handled incorrectly; thanks for noticing.

Duncan Murdoch

On 17/12/2009 4:05 AM, henrik.parn@bio.ntnu.no wrote:
> Dear R developers,
>
>
> ?help.search
>
> ...opens a tab in my browser (Firefox 3.5.6, Win XP):
>
> http://127.0.0.1:31642/library/utils/html/help.search.html
>
> When I click on the link for "?", 
> (http://127.0.0.1:31642/library/utils/help/?)
> in the last line of "Details", I get an error message:
>
> "Server error: invalid response from R".
>
>
> Similarly,
>
> The link to "??" (http://127.0.0.1:31642/library/utils/help/??) found 
> under http://127.0.0.1:31642/library/utils/html/help.html "See also" 
> gives same error message.
>
>
> On the other hand, in the help text for "help" 
> (http://127.0.0.1:31642/library/utils/html/help.html) the link to "?", 
> found under "See also", is 
> http://127.0.0.1:31642/library/utils/html/Question.html, which seems to 
> be the correct link.
>
>
> I did not manage to find anything on this topic in recent bug reports on 
> "Documentation" and "Documentation fixed".
>
>
> Best regards,
>
>
> Henrik Pärn
>
>
>  > sessionInfo()
> R version 2.10.1 (2009-12-14)
> i386-pc-mingw32
>
> locale:
> [1] LC_COLLATE=English_United Kingdom.1252  LC_CTYPE=English_United 
> Kingdom.1252    LC_MONETARY=English_United Kingdom.1252 LC_NUMERIC=C 
>
> [5] LC_TIME=English_United Kingdom.1252
>
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods   base
>
> loaded via a namespace (and not attached):
> [1] tools_2.10.1
>
>   	
>

Comment 3 Jitterbug compatibility account 2009-12-18 13:31:00 UTC
NOTES:
 Fixed in 2.10.1 patched
Comment 4 Jitterbug compatibility account 2009-12-18 13:31:13 UTC
Audit (from Jitterbug):
Fri Dec 18 07:31:13 2009	ripley	changed notes
Fri Dec 18 07:31:13 2009	ripley	moved from incoming to Documentation-fixed