Bug 14045 - Typo in R Help INSTALL {utils}
Typo in R Help INSTALL {utils}
Status: RESOLVED FIXED
Product: R
Classification: Unclassified
Component: Documentation
old
All Mac OS X v10.5
: P5 normal
Assigned To: Jitterbug compatibility account
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-06 01:01 UTC by Jitterbug compatibility account
Modified: 2010-03-22 08:37 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jitterbug compatibility account 2009-11-06 01:01:23 UTC
From: neilt@neiltiffin.com
Full_Name: Neil Tiffin
Version: R version 2.10.0 (2009-10-26) 
OS: [R.app GUI 1.30 (5511) i386-apple-darwin9.8.0] 
Submission from: (NULL) (99.68.31.116)


In  the help section 'INSTALL {utils}'  half way down the page the line

Use R CMD INSTALL –help for concise usage information, including all the
available options

should have two '-' in front of help.  Therefor it should read

Use R CMD INSTALL –-help for concise usage information, including all the
available options

At least when I copied and pasted the line it did not work until I added the
second '-'.

Comment 1 Jitterbug compatibility account 2009-11-06 04:13:43 UTC
From: Prof Brian Ripley <ripley@stats.ox.ac.uk>
The source file reads

   Use \command{R CMD INSTALL --help} for concise usage information,

so I see no 'typo'.

The issue is apparently in the rendering of -- as - in \command.  I 
am presuming you are viewing HTML in the Mac GUI, but can you please 
confirm exactly what you are looking at.

On Thu, 5 Nov 2009, neilt@neiltiffin.com wrote:

> Full_Name: Neil Tiffin
> Version: R version 2.10.0 (2009-10-26)
> OS: [R.app GUI 1.30 (5511) i386-apple-darwin9.8.0]
> Submission from: (NULL) (99.68.31.116)
>
>
> In  the help section 'INSTALL {utils}'  half way down the page the line
>
> Use R CMD INSTALL ?help for concise usage information, including all the
> available options
>
> should have two '-' in front of help.  Therefor it should read
>
> Use R CMD INSTALL ?-help for concise usage information, including all the
> available options

I suspect from the ? I see (twice) in your message that you are 
seeing an endash and not a single hyphen.  That's what HTML help on 
Linux is showing as for me.

> At least when I copied and pasted the line it did not work until I added the
> second '-'.

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

Comment 2 Jitterbug compatibility account 2009-11-06 22:51:00 UTC
NOTES:
 Worded around in 2.10.0 patched
Comment 3 Jitterbug compatibility account 2009-11-06 22:51:28 UTC
Audit (from Jitterbug):
Fri Nov  6 16:51:27 2009	ripley	changed notes
Fri Nov  6 16:51:28 2009	ripley	moved from incoming to Documentation