Bug 13463 - Italics in svg output display as bold
Italics in svg output display as bold
Status: CLOSED FIXED
Product: R
Classification: Unclassified
Component: System-specific
old
All Mac OS X v10.4
: P5 normal
Assigned To: R-core
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 03:55 UTC by Jitterbug compatibility account
Modified: 2014-02-16 11:43 UTC (History)
2 users (show)

See Also:


Attachments
(12.44 KB, application/octet-stream)
2009-01-22 17:58 UTC, Jitterbug compatibility account
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jitterbug compatibility account 2009-01-22 03:55:05 UTC
From: yan@pixie.org.uk
Full_Name: Yan Wong
Version: 2.8.1
OS: Mac OS X 10.4
Submission from: (NULL) (78.149.167.246)


When printing a plot to and svg file, text intended to be in italics is rendered
in bold (svg file viewed using both Safari 3.2.1 and Firefox 2.0.0.9.

For example, try viewing the test.svg file generated by

svg("test.svg", width=4,4,8)
plot.new(); text(0.5,0.5,labels=expression(italic("This should be in
italics")))
dev.off()

Yan

Comment 1 Jitterbug compatibility account 2009-01-22 17:58:38 UTC
From: Brian D Ripley <ripley@stats.ox.ac.uk>
PARTS: 2
It is a bug on your system: this is done by cairographics, and I 
suspect that the version you have is broken (or possibly your viewer).
I'll attach the version I get, which does display in italics on my 
system.

I used cairo-1.8.0-1.fc10.x86_64 (on Fedora 10).


On Wed, 21 Jan 2009, yan@pixie.org.uk wrote:

> Full_Name: Yan Wong
> Version: 2.8.1
> OS: Mac OS X 10.4

And how did you compile it?  This might be a bug in the cairographics 
or fontconfig library used for the CRAN binary build, if you used that 
(and report such issues to R-sig-mac -- see the posting guide).

> Submission from: (NULL) (78.149.167.246)
>
>
> When printing a plot to and svg file, text intended to be in italics is rendered
> in bold (svg file viewed using both Safari 3.2.1 and Firefox 2.0.0.9.
>
> For example, try viewing the test.svg file generated by
>
> svg("test.svg", width=4,4,8)
> plot.new(); text(0.5,0.5,labels=expression(italic("This should be in
> italics")))
> dev.off()
>
> Yan
>
> ______________________________________________
> R-devel@r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel
>

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595
(Attached 'test.svg' of type 'APPLICATION/octet-stream')

**END
Comment 2 Jitterbug compatibility account 2009-01-22 17:58:38 UTC
Created attachment 1049 [details]
Comment 3 Jitterbug compatibility account 2009-01-22 18:03:00 UTC
NOTES:
 Not reproducible on Linux, done by cairo
Comment 4 Jitterbug compatibility account 2009-01-22 18:03:17 UTC
Audit (from Jitterbug):
Thu Jan 22 13:03:17 2009	ripley	changed notes
Thu Jan 22 12:03:17 2009	ripley	moved from incoming to System-specific
Comment 5 Jitterbug compatibility account 2009-01-23 04:39:13 UTC
From: Yan Wong <yan@pixie.org.uk>
On 22 Jan 2009, at 11:58, Brian D Ripley wrote:

> It is a bug on your system: this is done by cairographics, and I  
> suspect that the version you have is broken (or possibly your viewer).
> I'll attach the version I get, which does display in italics on my  
> system.

Thanks for that. I do see italics in your file using my 2 viewers, so  
I guess that the problem is not my viewer.

> And how did you compile it?  This might be a bug in the  
> cairographics or fontconfig library used for the CRAN binary build,  
> if you used that (and report such issues to R-sig-mac -- see the  
> posting guide).

Yes, apologies for not stating: this is the latest OS X binary build  
from CRAN. I'll report the issue to R-sig-mac as you advise.

Cheers

Yan

Comment 6 Brian Ripley 2010-04-11 15:10:55 UTC
Known problem with fontconfig on Mac OS X: no resolution as yet
Comment 7 Brian Ripley 2010-10-02 15:17:14 UTC
Workaround for the Mac OS X font problem (of which this is a symptom) added for 2.12.0
Comment 8 Jackie Rosen 2014-02-16 11:43:40 UTC
(spam comment removed)