Bug 14816

Summary: Windows installer in Chinese
Product: R Reporter: wangsong <mr.wangsong>
Component: InstallationAssignee: R-core <R-core>
Status: CLOSED FIXED    
Severity: minor CC: spider_xp
Priority: P5    
Version: R 2.14.1 patched   
Hardware: x86_64/x64/amd64 (64-bit)   
OS: Windows 64-bit   
Attachments: screen snapshoot
chinese vs english

Description wangsong 2012-02-16 02:58:41 UTC
When I install R 2.14.1 at Windows 7 Professional (with Chinese language).
I get some unreadable code on screen. I catch it. Please see attachment.
Comment 1 wangsong 2012-02-16 03:04:51 UTC
Created attachment 1270 [details]
screen snapshoot

Or  
http://dl.dropbox.com/u/61826294/R_installation.png
Comment 2 Brian Ripley 2012-02-16 13:17:54 UTC
On 16/02/2012 01:58, r-bugs@r-project.org wrote:
> https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14816
>
>             Summary: Multilingual support
>             Product: R
>             Version: R 2.14.1 patched
>            Platform: x86_64/x64/amd64 (64-bit)
>          OS/Version: Windows 64-bit
>              Status: NEW
>            Severity: minor
>            Priority: P5
>           Component: Installation
>          AssignedTo: R-core@R-project.org
>          ReportedBy: mr.wangsong@gmail.com
>     Estimated Hours: 0.0
>
>
> When I install R 2.14.1 at Windows 7 Professional (with Chinese language).
> I get some unreadable code on screen. I catch it. Please see attachment.
>


Can you please tell us *which* Chinese character set this was?  We don't 
read Chinese ....

Can you please also check R-devel, as AFAIK those parts do not appear in 
that version (which is the only one under development).


-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595


Comment 3 wangsong 2012-02-17 10:03:53 UTC
Created attachment 1272 [details]
chinese vs english

I reinstall with english, and  catch the same snapshoots
I arrange all snapshoots (chinese and english) in one file, and mark with red color. Please see the attachment.
Comment 4 Brian Ripley 2012-02-17 13:59:38 UTC
I ended up asking one of my students, who tells me it is Simplified Chinese.

This seems to be a change in the installer toolkit rather than R itself: I am working on a fix.
Comment 5 Brian Ripley 2012-02-17 15:13:18 UTC
On 17/02/2012 09:03, r-bugs@r-project.org wrote:
> https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14816
>
> --- Comment #3 from wangsong<mr.wangsong@gmail.com>  2012-02-17 04:03:53 EST ---
> Created an attachment (id=1272)
>   -->  (https://bugs.r-project.org/bugzilla3/attachment.cgi?id=1272)
> chinese vs english
>
> I reinstall with english, and  catch the same snapshoots
> I arrange all snapshoots (chinese and english) in one file, and mark with red
> color. Please see the attachment.
>


Which Chinese?  There are both Simplified and Traditional Chinese 
versions of the installer.

Please do answer the question you were asked: we don't need more 
snapshots, but we do need to know exactly what you did.

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595


Comment 6 Brian Ripley 2012-02-17 21:49:45 UTC
The installer needed a BOM mark on a UTF-8 file now.
Comment 7 Brian Ripley 2012-02-24 11:18:52 UTC
*** Bug 14824 has been marked as a duplicate of this bug. ***
Comment 8 Peter Dalgaard 2012-02-24 15:38:07 UTC
Looks like another instance of bug #14816, so please check R-2.14.2-RC.

http://cran.r-project.org/bin/windows/base/R-2.14.2rc-win.exe

On Feb 17, 2012, at 10:03 , <r-bugs@r-project.org> <r-bugs@r-project.org> wrote:

> https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14816
> 
> --- Comment #3 from wangsong <mr.wangsong@gmail.com> 2012-02-17 04:03:53 EST ---
> Created an attachment (id=1272)
> --> (https://bugs.r-project.org/bugzilla3/attachment.cgi?id=1272)
> chinese vs english
> 
> I reinstall with english, and  catch the same snapshoots
> I arrange all snapshoots (chinese and english) in one file, and mark with red
> color. Please see the attachment.
> 
> -- 
> Configure bugmail: https://bugs.r-project.org/bugzilla3/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are the assignee for the bug.
> 
> _______________________________________________
> R-core list: https://stat.ethz.ch/mailman/listinfo/r-core
> 

-- 
Peter Dalgaard, Professor
Center for Statistics, Copenhagen Business School
Solbjerg Plads 3, 2000 Frederiksberg, Denmark
Phone: (+45)38153501
Email: pd.mes@cbs.dk  Priv: PDalgd@gmail.com