Bug 14698

Summary: RGui crashes when printing specific data frame in R Console
Product: R Reporter: Sebastiaan Meijer <sjjmeijer+RBugzilla>
Component: Windows GUI / Window specificAssignee: R-core <R-core>
Status: CLOSED FIXED    
Severity: major CC: ligges
Priority: P5    
Version: R 2.14.0   
Hardware: x86_64/x64/amd64 (64-bit)   
OS: Windows 64-bit   

Description Sebastiaan Meijer 2011-10-09 18:15:14 UTC
When printing the SLID dataframe from the car library (7425 rows, 5 columns), in the R Console the RGui application stops resplonding and starts using increasing amounts of memory.

Code to reproduce the bug:
1. Install car package
2. Execute the following code:

> libary(car)
> SLID

Expected output: The data frame is shown in the console.

Actual output: The application stops responding, and starts consuming increasing amounts of memory for about 20 seconds until the system memory is full (>850 MB in my case) and Windows stops responding due to a lack of memory.

Build date & Platform: Version 2.13.1 Build (2011-07-08) 64 bit. Platform: Windows 7 x64 Professional (6.1.7601)

Alternate Build date & Platform: Version 2.13.2 Build (2011-09-30) 32 and 64 bit. Version 2.13.1 Build (2011-07-08) 32 bit on Windows 7 x64 Professional (6.1.7601).

Additional Information:

The commandline version prints the dataset without any problems. All kinds of operations (e.g. lm, fivenum, etc.) on the dataset seem to work too. When specifying the number of rows in the dataset to print (i.e. SLID[1:7425,]) the dataset is displayed correctly in the R console within a second.

The machine on which the bug occurs has the following specifications:
Processor: VIA Nano U2250 (1.3GHz+)
Memory: 2 GB DDR2
OS: Windows 7 Professional 64-bit

The bug has been confirmed to occur on another machine, which has the following specifications:
Processor: AMD Phenom II X3 720
Memory: 4 GB DDR3
OS: Windows 7 64-bit running Version 2.13.1 Build (2011-07-08) 64 bit.
Comment 1 Duncan Murdoch 2011-10-10 06:26:01 UTC
I don't have a 64 bit machine available until Tuesday.  I tried this on 
32 bit R, and saw no problem.

Duncan Murdoch

On 11-10-09 1:15 PM, r-bugs@r-project.org wrote:
> https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14698
>
>             Summary: RGui crashes when printing specific data frame in R
>                      Console
>             Product: R
>             Version: R 2.13.1 patched
>            Platform: x86_64/x64/amd64 (64-bit)
>          OS/Version: Windows 64-bit
>              Status: NEW
>            Severity: major
>            Priority: P5
>           Component: Windows GUI / Window specific
>          AssignedTo: R-core@R-project.org
>          ReportedBy: sjjmeijer+RBugzilla@gmail.com
>     Estimated Hours: 0.0
>
>
> When printing the SLID dataframe from the car library (7425 rows, 5 columns),
> in the R Console the RGui application stops resplonding and starts using
> increasing amounts of memory.
>
> Code to reproduce the bug:
> 1. Install car package
> 2. Execute the following code:
>
>> libary(car)
>> SLID
>
> Expected output: The data frame is shown in the console.
>
> Actual output: The application stops responding, and starts consuming
> increasing amounts of memory for about 20 seconds until the system memory is
> full (>850 MB in my case) and Windows stops responding due to a lack of memory.
>
> Build date&  Platform: Version 2.13.1 Build (2011-07-08) 64 bit. Platform:
> Windows 7 x64 Professional (6.1.7601)
>
> Alternate Build date&  Platform: Version 2.13.2 Build (2011-09-30) 32 and 64
> bit. Version 2.13.1 Build (2011-07-08) 32 bit on Windows 7 x64 Professional
> (6.1.7601).
>
> Additional Information:
>
> The commandline version prints the dataset without any problems. All kinds of
> operations (e.g. lm, fivenum, etc.) on the dataset seem to work too. When
> specifying the number of rows in the dataset to print (i.e. SLID[1:7425,]) the
> dataset is displayed correctly in the R console within a second.
>
> The machine on which the bug occurs has the following specifications:
> Processor: VIA Nano U2250 (1.3GHz+)
> Memory: 2 GB DDR2
> OS: Windows 7 Professional 64-bit
>
> The bug has been confirmed to occur on another machine, which has the following
> specifications:
> Processor: AMD Phenom II X3 720
> Memory: 4 GB DDR3
> OS: Windows 7 64-bit running Version 2.13.1 Build (2011-07-08) 64 bit.
>



Comment 2 Brian Ripley 2011-11-04 12:49:45 UTC
Can we please have the sessionInfo(): we need to know the locale that this was run under.

And please also report if 2.14.0 shows the problem.
Comment 3 Uwe Ligges 2011-11-04 14:07:34 UTC
Confirmed for both 32 and 64 bit R-release (2.14.0): memory footprint increases up to the limit (32bit) or killed at 5gB by myself (64-bit).

R version 2.14.0 (2011-10-31)
Platform: x86_64-pc-mingw32/x64 (64-bit)

locale:
[1] LC_COLLATE=C                 LC_CTYPE=German_Germany.1252
[3] LC_MONETARY=C                LC_NUMERIC=C                
[5] LC_TIME=C                   

attached base packages:
[1] splines   stats     graphics  grDevices utils     datasets  methods  
[8] base     

other attached packages:
[1] car_2.0-11       survival_2.36-10 nnet_7.3-1       MASS_7.3-16     



 
R version 2.14.0 (2011-10-31)
Platform: i386-pc-mingw32/i386 (32-bit)

locale:
[1] LC_COLLATE=C                 LC_CTYPE=German_Germany.1252
[3] LC_MONETARY=C                LC_NUMERIC=C                
[5] LC_TIME=C                   

attached base packages:
[1] splines   stats     graphics  grDevices utils     datasets  methods  
[8] base     

other attached packages:
[1] car_2.0-11       survival_2.36-10 nnet_7.3-1       MASS_7.3-16     


Uwe
Comment 4 Brian Ripley 2011-11-05 06:27:25 UTC
This was a bug in the fix for PR#14357

The cause is trying to output too many items between R calls: it seems
the limit was about 25,000.