Bug 15017 - Clicking preference pane causes seq fault that kills R
Summary: Clicking preference pane causes seq fault that kills R
Alias: None
Product: R
Classification: Unclassified
Component: Mac GUI / Mac specific (show other bugs)
Version: R 2.15.1 patched
Hardware: x86_64/x64/amd64 (64-bit) Mac OS X v10.8
: P5 normal
Assignee: Simon Urbanek
: 15022 (view as bug list)
Depends on:
Reported: 2012-08-13 19:36 UTC by Sven Laur
Modified: 2012-12-13 03:33 UTC (History)
4 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Sven Laur 2012-08-13 19:36:37 UTC
Platform: Mac OS X 10.8

If one opens preference pane and clicks onto the region Show All GUI crashes with the error

*** caught segfault ***
address 0x1027e8000, cause 'memory not mapped'

The error does not occur if you click on any other sub-pane.
Comment 1 Brian Ripley 2012-08-15 11:36:04 UTC
I am assuming this is a report on R.app, the OS X GUI which is a separate product managed by a different team.

Please report problems with that to the R-sig-mac list.
Comment 2 Simon Urbanek 2012-08-15 14:52:53 UTC
In addition, it is not reproducible (at least not on our binary R.app). If you intend to report, please supply full sessionInfo() as well as the GUI version string. Preferably, also attach the crash report.
Comment 3 Simon Urbanek 2012-08-17 16:54:15 UTC
*** Bug 15022 has been marked as a duplicate of this bug. ***
Comment 4 Samir Bajaj 2012-09-15 20:42:56 UTC
Does this help?

I installed R for the very first time ever, and I ran into a seg fault before I could type my first command.

All I tried to do is change the font size in the preferences pane.

Very disappointing.

R version 2.15.1 (2012-06-22) -- "Roasted Marshmallows"
Copyright (C) 2012 The R Foundation for Statistical Computing
ISBN 3-900051-07-0
Platform: i386-apple-darwin9.8.0/i386 (32-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

  Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

[R.app GUI 1.52 (6188) i386-apple-darwin9.8.0]

 *** caught segfault ***
address 0x8eff000, cause 'memory not mapped'

Possible actions:
1: abort (with core dump, if enabled)
2: normal R exit
3: exit R without saving workspace
4: exit R saving workspace
Comment 5 David Holstius 2012-12-13 03:33:24 UTC
I experienced this bug after upgrading from OS X 10.7 (+ R 2.15.1) to OS X 10.8. 

I then upgraded R to 2.15.2, but that didn't help. 

I can replicate this bug every time I launch R.app or R64.app, with no packages loaded and nothing in the workspace:

[R.app GUI 1.53 (6335) x86_64-apple-darwin9.8.0]

[History restored from /Users/holstius/Dropbox/r/.Rhistory]

> ls()
> sessionInfo()
R version 2.15.2 (2012-10-26)
Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit)

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

 *** caught segfault ***
address 0x101674000, cause 'memory not mapped'